Payment with MasterPass not working
Incident Report for Urban Sharing Platform
Resolved
We disabled the MasterPass payment option.
Posted over 1 year ago. Apr 25, 2018 - 20:06 CEST
Identified
A technical problem between our payment provider and MasterCard results in MasterPass payments not working.
Posted over 1 year ago. Apr 24, 2018 - 23:31 CEST