Issues with buying subscriptions
Incident Report for Urban Sharing Platform
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 19, 2019 - 10:09 CEST
Update
We're still working on a fix for this issue.
Posted 4 months ago. Jun 18, 2019 - 17:31 CEST
Identified
We are seeing issues affecting some customers when buying subscriptions. We have identified the issue and are working on fixing it.
Posted 4 months ago. Jun 18, 2019 - 16:14 CEST
This incident affected: Payment services.