Login SMS codes not delivered
Incident Report for Urban Sharing Platform
Resolved
This incident has been resolved.
Posted 10 months ago. Aug 25, 2018 - 12:45 CEST
Investigating
We are currently investigating this issue.
Posted 10 months ago. Aug 25, 2018 - 12:31 CEST