We are currently experiencing intermittent website outages
Incident Report for Urban Sharing Platform
Resolved
This incident has been resolved.
Posted Jul 30, 2022 - 11:58 CEST
Investigating
We are currently investigating this issue.
Posted Jul 30, 2022 - 11:15 CEST
This incident affected: Web sites (Trondheim City Bike web site, Bergen City Bike web site, Oslo City Bike Web Site, Verona Bike web site, BikeMi Milan City Bikes).