Issues with 3rd party payment service
Incident Report for Urban Sharing Platform
Resolved
Our payment provider PayEx has informed us this incident has been resolved.
Posted Oct 02, 2020 - 12:28 CEST
Update
We are not seeing any failed payments so far, and the impact therefore seems to be low. We will provide an update if this changes, or if we get more details from the 3rd party payment provider (PayEx)
Posted Oct 02, 2020 - 12:04 CEST
Investigating
Our 3rd party payment provider PayEx just reported that they have an issue with "Payment callbacks", which can affect customers ability to buy subscriptions and sign up to the service. We do not yet know the impact of the issue, but are awaiting more information from PayEx.
Posted Oct 02, 2020 - 11:29 CEST
This incident affected: Payment services.